Составить программу-тренажер «устный счет от 10 до 100», предъявляющую пользователю поочередно примеры на проверку навыков устного счета и проверяющую правильность вычисления пользователем. программа должна выводить на экран произвольные два двузначных числа и знак «+» или «-» между ними. потом пользователь должен ввести свой ответ, а программа проверяет правильность вычислений.

Mino6 Mino6    2   23.05.2019 14:23    3

Ответы
fedosovdenis28 fedosovdenis28  19.06.2020 09:50

Begin

A :=random(100);

B :=random(100);

If 50>random(100) then ch:='+'

Else ch:='-';

Write(a,ch,b);

Read(o);

If (ch='+' and a+b=o) or (ch='-' and a-b=o) then write('ok')

Else write('wrong');

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика