tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
составить программу табулирования
составить программу табулирования функции заданной рекурентной формулой. f(0)=1; f(1)=2; f(n+2)=2*f(n+1)-n
аноним1234567891011
3 13.06.2019 20:20
3
Ответы
Fantom511
10.07.2020 18:21
Function f(n:integer): integer;
begin
if n=0 then f := 1
else if n=1 then f := 2
else f := 2*f(n-1)-n+2;
end;
var n: integer;
begin
writeln('n':5, 'f(n)':10);
for n := 0 to 20 do
writeln(n:5, f(n):10);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
danyok132006
29.07.2019 07:50
Население города едегодно увеличивается на 1/40 наличного состава жителей ( сейчас в нем 240 000) через сколько лет население города утроится? pascal...
живууууу
29.07.2019 07:50
Запишите ip-адрес из 4-х десятичных чисел в 32-битном виде 1) 192.65.177.152 2) 255.24.216.201 3) 49.87.202.143...
bulkin12
29.07.2019 07:50
Кирилл решил потренироваться в сложных высказываниях. он заявил: «сегодня либо пойдёт дождь, либо будет сухо. завтра в школе будет контрольная по информатике. если я...
marina999mmm
29.07.2019 07:50
Паскаль abc пользователь вводит с клавиатуры два числа. если сумма чисел больше, либо равна 100, то программа выводит «разряд выше десятков», если сумма меньше 100,...
SpecialCat
29.07.2019 07:40
Вдвумерном массиве найти произведение всех отрицательных элементов...
bigman4
29.07.2019 07:40
Дан массив, содержащий 2016 положительных целых чисел, не превышающих 1000. необходимо найти и вывести максимальный из тех элементов этого массива, чётность которых...
Vitaminka123456789
29.07.2019 07:40
Информатика! ! объём информационного сообщения равен 2^22 бит. чему равен объём этого сообщения в мбайтах? ответ дайте в степенях двойки. с объяснением...
fox590
29.07.2019 07:40
Ввелокроссе участвуют 779 спортсменов. специальное устройство регистрирует прохождение каждым из учеников промежуточного финиша, записывая его номер с использованием...
Mашуня1111
29.07.2019 07:40
Сообщение о том , что вася живет в 3 подъезде несёт 2 бита информации. сколько подьездов?...
alenka199918
29.07.2019 07:40
1)253 в шестеричной=х в десятеричной 2) 101010 в двоичной =х в десятеричной 3) 234 в пятеричной =х десятеричной надо решить в столбик...
Популярные вопросы
Головні герої твору Чаклунство наполовину....
2
АС- дотична,,а АВ -хорда колаз центром в точці О.Кут ВАС=75 градусів....
1
Күн жүйесінде деген диалог құру қысқаша. Көмектесіп жібересіздерме...
3
Киргизский эпос Манас сохранился до настоящего времени благодаря...
2
20г води и 5г NaCl.Знайти масову частку солі в розчин...
3
На які деталі історичної події звертає увагу літописець, чому саме...
1
Дайте ответы на во не сильно кратко (на 5-6 предложений)1.Кем мечтал...
3
Чи кохає насправді Лукаш Мавку ?...
2
Определите, верны (+) или неверны (−) следующие утверждения. Прямой...
1
СХЕМА ДО РЕЧЕНЬ:1)чи не на всіх картинах козак Мамай- вродливий січовик...
1
begin
if n=0 then f := 1
else if n=1 then f := 2
else f := 2*f(n-1)-n+2;
end;
var n: integer;
begin
writeln('n':5, 'f(n)':10);
for n := 0 to 20 do
writeln(n:5, f(n):10);
end.