tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу
Составить программу суммирования натуральных чисел пока их сумма не превысит величину h. вывести на экран последнее слагаемое и сумму
ilia200575
2 27.05.2019 19:20
3
Ответы
egor570
24.06.2020 21:44
Readln(n,h);
for i:=1 to n do begin
s:=s+i;
if s>h then
break;
end;
writeln(i,s);
ПОКАЗАТЬ ОТВЕТЫ
FFFFFF1223
24.06.2020 21:44
Uses crt;
var n,h,i,sum:integer;
begin
read(n,h);
while sum<=h do
begin
sum+=i;
i+=1;
end;
writeln(i-1,' ',sum-i);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
fgggg2qq
04.04.2020 21:07
На вході маємо ціле число,яке запитується в користувача.Програма переводить його в текст та виводить результат,додаючи до нього символ ! в кінець (не використовувати додаткові...
BlacYT
04.04.2020 21:14
Определите, какое число будет напечатано в результате выполнения следующего алгоритма: Var a,b,t,M,R:integer; Function F(x:integer):integer; begin F:=-(x+4)*(x+2); end; BEGIN...
vkuke
04.04.2020 21:16
Зіставте назви методів з їх призначенням...
Smazi
04.08.2019 12:00
На паскале. 99 два юных шамана егор и саша отправились на всероссийский конкурс опытных шаманов профессионалов. до места проведения вкошп можно добраться только на поезде....
danekhakker
04.08.2019 12:00
Паскаль.дан массив из 100 элементов. необходимо заполнить первые n из них первыми n натуральными числами в порядке возрастания формат входных данных с клавиатуры вводится...
rizhik68
13.05.2020 18:47
Дана блок-схема. Какое значение будет иметь z на выходе, если x=38? (промежуточные вычисление не округляйте; ответ округли до десятых...
йцывапенрошщдлро
13.05.2020 18:47
Не үшін кейип кердын кастюнын ауыстрамыз...
Keks200220
13.05.2020 18:47
26. Была получена телеграмма: «Встречайте, вагон 7». Известно, что в составе поезда 8 вагонов. Какое количество информации (в битах) было получено?...
Ерко365
22.05.2019 17:36
Используя цикл, составьте программу для решения в результате эксперимента получены некоторые целые числа. эксперимент моно считать успешным, если показания не убывают и среди...
diankapazyukа
30.09.2019 12:50
Дана последовательность из нулей и единиц. признаком окончания является число -1. определить количество максимально подряд ищущих нулей. -решить на языке pascal...
Популярные вопросы
Разделить слово енот на слоги,сколько звуков в первом слоге?...
2
Магазин закупает цветочные горшки по оптовой цене 120 рублей за штуку...
2
Семья николаевых решила отдохнуть летом за границей.рассчитав свой довольно...
1
Напишите сочинение по теме является ли изба и баня родственными ? ....
1
97218: 982= 460598: 792= 144560: 695= 1107738: 369= решите в столбиком...
1
Составить 7 предложений на тему мой любимый вид спорта.!...
3
Текст на казахском языке на тему школьшые каникулы...
1
Почему на реке лене нет порогов и водопадов, а на её притоке вилюе есть?...
3
Укажите слово, в котором число букв равно числу звуков а) январь б) сильно...
2
1) построить график функции: 1) y=2x; 2) y=x-2; 3) y=3; 4) y=3-4x....
3
for i:=1 to n do begin
s:=s+i;
if s>h then
break;
end;
writeln(i,s);
var n,h,i,sum:integer;
begin
read(n,h);
while sum<=h do
begin
sum+=i;
i+=1;
end;
writeln(i-1,' ',sum-i);
end.