Составить программу.сформировать одномерный массив n=10 a[i]=i^3 1 8 найти сумму 1-го,5-го и последнего элемента.

LastGirlOnEarth LastGirlOnEarth    2   28.07.2019 12:30    4

Ответы
Vanpal03 Vanpal03  03.10.2020 15:35
Const
    n = 10;

var
    a: array[1..n] of integer;
    i: integer;

begin
    for i := 1 to n do
        a[i] := i * i * i;
    
    writeln(a[1] + a[5] + a[n]);
end.
ПОКАЗАТЬ ОТВЕТЫ
slolia slolia  03.10.2020 15:35
1. Короткий вариант

// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var a:=1.To(10).Select(x->x*x*x).ToArray; a.Println;
  Writeln('s=',a[0]+a[4]+a[9])
end.

Результат
1 8 27 64 125 216 343 512 729 1000
s=1126

2. Школьный вариант

// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
var
  i:integer;
  a:array[1..10] of integer;
begin
  for i:=1 to 10 do begin
    a[i]:=i*i*i;
    Write(a[i],' ')
    end;
  Writeln;
  Writeln('s=',a[1]+a[5]+a[10])
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика