составить программу с процедурой выводящую на экран 4 горизонтальные линии из символов ''*'':1 линия -7 символов,2 линия-19 символов,3 и 4 линия любое количество символов(<80,количество символов вводить с клавиатуры).Написать в паскале

djugju djugju    1   11.06.2021 15:56    5

Ответы
kristimilafffka kristimilafffka  11.07.2021 15:58

Код программы:

procedure print(a, b:integer);

var i:integer;

begin

 for i:=1 to 7 do

   write('*');

 writeln();

  for i:=1 to 19 do

   write('*');

  writeln();

  for i:=1 to a do

   write('*');

   writeln();

  for i:=1 to b do

   write('*');

end;  

var a,b:integer;

begin

 writeln('Введите количество символов на 3 уровне(<80): ');

 readln(a);

 writeln('Введите количество символов на 4 уровне(<80): ');

 readln(b);

 if (a < 80) and (b < 80) then

     print(a,b)

 else

   writeln('Ошибка! Количество символов >= 80');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика