Составить программу, резервирующую массив из 100 элементов для хранения целых чисел, заполняет его случайными числами (процедура random) и выводит на экран среднее арифметическое значение элементов массива. В программе выделить процедуру заполнения (назовем ее CreateRandomArray) и функцию вычисления среднего арифметического значения массива (пусть это будет MediaArray). Передача данных в процедуры выполняется по ссылке , очень сильно нужно.

Элина177862006 Элина177862006    2   04.01.2022 04:58    2

Ответы
analekss analekss  15.02.2022 15:04

#include <iostream>

#include <cstdlib>

#include <ctime>  

using namespace std;  

int main()

{

setlocale(LC_ALL, "rus");  

int randomDigit = 0;

int version = 0;  

srand(time(NULL));

randomDigit = 1 + rand() % 7;  

cout << "Отгадайте число, которое я загадал (1-7):";

cin >> version;  

if (version == randomDigit)

{

 cout << "Дa! Я загадал число - " << randomDigit << endl;

}

else

{

 cout << "Нет! Я загадал число - " << randomDigit << endl;

}  

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика