Составить программу решения ах2+вх+с=0,а,в не равно нулю.проверить случай ,когда дискриминант болmше нуля меньше нуля и равен нулю.

bts23 bts23    1   07.07.2019 11:00    3

Ответы
bugumot bugumot  30.07.2020 18:17
 program ii;  
                var A, B, C, D: real; 
                  begin   
  writeln ('Введите коэффициенты А, В, С'); 
   readln (A, B, C);   
  if A=0     then
 writeln ('Уравнение не квадратное')
     else
begin
 D := B*B - 4*A*C; 
A := 2*A;
if D<0 then
writeln ('Действительных корней нет')
else
 if D=0 then
writeln ('Корни равны: X1 = X2 = ', -B/A)
else 
   begin       
  D := sqrt(D);      
    writeln ('X1 = ', (-B+D)/A);writeln ('X2 = ', (-B-D)/A); 
  end;        end;              end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика