Составить программу расчета нормы полива в теплице (л/м) по формуле: m=0,1*h*d* где h – высота слоя грунта, см; d – объемная масса грунта, г/см3; w1 – рекомендуемая относительная влажность грунта, % ппв; w2 – фактическая относительная влажность грунта, % ппв. фактическая относительная влажность грунта изменяется в пределах от 50 до 60 % ппв с шагом 1 %.

Настя55251 Настя55251    3   03.06.2019 23:10    9

Ответы
olgaaaaaa13 olgaaaaaa13  05.07.2020 06:46
//Если я правильно понял, то так...
var
  d, h, w1, w2: integer;

function readvalue(s: string): integer;
var t: integer;
begin
  write(s, ' ');
  readln(t);
  result := t;
end;

begin
  h := readvalue('Высота слоя грунта:');
  d := readvalue('Объём грунта:');
  w1 := readvalue('Рек. влажность грунта:');
  writeln('Вл. грунта | Норма полива');
  for w2 := 50 to 60 do
    writeln(w2:9, '% | ', 0.1*h*d*(w1-w2), ' л/м');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика