:составить программу расчёта числа загонов (шт.) на пастбище по формуле: к=п/д+з, где п-период, необходимый для отрастания травы на пастбище, дн.; д- количество дней пастьбы для скота в каждом загоне, дн.; з- потребное количество загонов для возобновления травостоя, шт.; количество дней пастьбы скота изменяется в пределах от 1 до 5 дней с шагом 1 день.

Digger2001 Digger2001    2   02.06.2019 01:20    1

Ответы
Abdulla234 Abdulla234  02.07.2020 22:58
Program qq;
uses crt;
var p, d, z, i: integer; k:real;
begin
writeln('Введите период для отрастания травы в днях:');
readln(p);
writeln('Введите потребное количество загонов:');
readln(z);
for i:=1 to 5 do
    begin
    d:=i; // переменная дней изменяется, как дано в условии от 1 до 5 дней
    k:=round(p/d+z); //процедура round округляет по всем правилам число загонов. Ведь весьма нелогично строить, например 3,3333 загона:)
    writeln ('Для количества дней пастьбы - ', d,' требуется загонов - ',k);
    end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика