tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу, проверяющую
Составить программу, проверяющую есть ли цифра n в числе , введённом с клавиатуры. pascal abc. (не копируйте с других источников, неправильно)
УмничкаХороша
3 19.09.2019 01:30
5
Ответы
мирби1
08.10.2020 01:12
Program n1;
var a,n: integer;
f: byte;
begin
f:=0;
readln(a,n);
while a<>0 do
begin
if a mod 10=n then f:=1;
a:=a div 10;
end;
if f=1 then write('цифра ',n,' присутствует в числе')
else write('в числе нет цифры ',n);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Anreynechay
24.05.2021 21:03
Данные массивы целых чисел {ai} (i = 1,2, ...), и {bj} (j = 1,2, ...,), а также целое число k. Если в массиве a нет ни одной элемента со значением k, то первый по порядку элемент...
MainkraeTV
24.05.2021 20:59
Скласти програму для обчислення суми k членів ряду, де k визначається з критерію, що ||Uk| -|Um|| з та з - наперед задана точність обчислення та m=k+1. При вводі даних необхідно...
MudriyMudrec
19.07.2019 23:00
Что такое обработка информации? приходилось ли вам обрабатывать информацию? 2 примера. в чем различие между первым и вторым типами обработки информации? что вы понимаете под...
адинаа1
01.02.2021 13:31
Перевести алгоритм в математический вид a1 := 4 / (23x) a2 := a1 / x a3 := a2 / x a4 := a3 / x y := a1 + a4...
misha426
01.02.2021 13:32
9 номер Очень нужно Паскаль а б с...
anastasiaperova
29.05.2019 19:10
Добрый день. решить две №1 дан массив из 25 элементов,найти сумму 4-х наибольших и 4-х наименьших элементов. результат распечатать в виде: сумма наибольших= сумма наименьших=...
nastyaignatova3
27.04.2020 09:06
Упражнение 1. Раскройте скобки. Образуйте существительные.1. The study calculated that replacing weekly fruit juice ... with whole fruits could bring healthbenefits. (consume)2....
vikulazvezdocka
27.04.2020 09:06
Решите пример по действиям. ...
yoanna0900
27.04.2020 09:06
ЕСЛИ ВАМ НЕ СЛОЖНО ПОЖАЙЛУСТА 1 Какие из нижеперечисленных реформ Столыпина были необходимы в России для завершения процесса модернизации?A) свобода вероисповеданияБ) гражданское...
Lagunahey
27.04.2020 09:06
Органоид, в котором находится наследственная информация * Подпись отсутствует 1. 3 2. 5 3. 6 Органоид, в котором находится пигмент Подпись отсутствует 1. 3 2. 5 3. 6...
Популярные вопросы
Валютный паритет, представляющий собой официально установленное соотношение...
3
Нормативное и правовое регулирование финансовых операций осуществляется...
3
Под _ понимается вероятность убытка или упущенной выгоды, неуверенность...
1
Согласно словарю _, форвардный курс определяется как спот-курс плюс премия...
2
25% от взноса стран-участниц МВФ в его капитал в настоящее время вносится...
1
Если четыре автомобиля марки «Форд» стоят в США столько же, сколько три...
2
Вид факторинга, при котором покупателю известно о переуступке денежных требований...
2
Срок обращения сберегательного сертификата ограничен тремя годами двумя...
2
Чем выше курс иностранной валюты, тем: меньше спрос на нее сильнее ее позиции...
3
Для расчета величины минимальной ПД составляется уравнение, в котором _...
3
var a,n: integer;
f: byte;
begin
f:=0;
readln(a,n);
while a<>0 do
begin
if a mod 10=n then f:=1;
a:=a div 10;
end;
if f=1 then write('цифра ',n,' присутствует в числе')
else write('в числе нет цифры ',n);
end.