Составить программу преобразования заданных действительных значений x и y по правилу: если x и y отрицательны, то каждое значение заменить его модулем; если отрицательно только одно из них, то оба значения увеличить в 2 раза; в остальных случаях оба значения заменить квадратным корнем. p.s. делается всё в pascalabc.net

Ольгаok Ольгаok    2   01.07.2019 07:50    4

Ответы
superpuper90 superpuper90  24.07.2020 17:56
Var x,y:real; 
      begin 
  writeln('x='); 
        readln(x);
    writeln('y='); 
   readln(y); 
    if (x<0) and (y<0)
 then
writeln (abs(x), ' ',abs(y)); 
      if (x<0) and (y>0) or (x>0) and (y<0)
 then
writeln(2*x,' ', 2*y);

 if (x>0) and (y=0) or (x=0) and (y>0) or (x>0) and (y>0)
then
writeln( sqrt(x),' ',sqrt(y)); 
  readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика