Составить программу поиска в целочисленном массиве из 15 элементов двух рядом стоящих элементов, сумма которых больше 10, если таких элементов нет, вывести "no". в паскале.

svyatoslavkorchagin svyatoslavkorchagin    2   24.05.2019 08:50    2

Ответы
anosovadara anosovadara  20.06.2020 05:54
Const n=15;
var
a: array [1..n] of integer;
i:integer;
p:boolean;
begin
  p:=true;
  for i:= 1 to n do
  begin
    write('Введите A[',i,']: ');
    readln(a[i]);
  end;
  i:=1;
  while p and (i<n) do
  begin
    if a[i]+a[i+1]>10 then
      begin
        p:=false;
        writeln;
        writeln('(A[',i,']=',a[i],') + ((A[',i+1,']=',a[i+1],') > 10');
      end;
    inc(i);
  end;
  writeln;
  if p then writeln('NO');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика