Составить программу по информатике в pascal abc. 1. с клавиатуры одной строковой вводят имя и фамилию. составьте программу, которая: а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и
выводит его; в) выводит сначала фамилию, а затем имя. 2. составьте программу, которая в строке "касіу ясь канюшыну" заменяет имя "ясь" на "янка". 3. составьте программу, которая в строке "реки горы и болота": а) удаляет слово "горы";
б) заменяет слово "болота" на "озера". буду безмерно !

Лущік Лущік    1   01.03.2019 03:30    16

Ответы
vasylyna946 vasylyna946  06.06.2020 21:20

Задание 1

a)

program pr;

var

s:string;

c:char;

i:integer;

begin

writeln('Введите имя и фамилию в одной строке');

readln (s);

writeln('Введите заданный символ');

readln (c);

for i:=1 to length(s) do if s[i]=c then writeln ('В строке найден заданный символ');

readln;

end.

б)

program pr;

var

s,n:string;

c:char;

i:integer;

begin

writeln('Введите имя и фамилию в одной строке');

readln (s);

i:=1;

while s[i]<>' ' do i:=i+1;

n:=copy(s,1,i-1);

writeln(n);

readln;

end.

в)

program pr;

var

s,n,f:string;

c:char;

i:integer;

begin

writeln('Введите имя и фамилию в одной строке');

readln (s);

i:=1;

while s[i]<>' ' do i:=i+1;

n:=copy(s,1,i-1);

f:=copy(s,i+1,length(s)-i+1);

writeln(n);

writeln(f);

readln;

end.

Задание2

program pr;

var s:string;

begin

s:='Касіу Ясь канюшыну';

delete (s,7,3);

insert ('Ясь',s,7);

writeln (s);

readln;

end.

Задание 3

а)

program pr;

var

s:string;

begin

s:='реки горы и болота';

delete (s,6,5);{удаляем включая пробел}

writeln (s);

readln;

end.

б)

program pr;

var

s:string;

begin

s:='реки горы и болота';

delete(s,13,6);

s:=s+'озера';

writeln (s);

readln;

end.

 

 

 

 

 

 

 

 

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика