составить программу по информатике. Дано предложение. Вычислить сколько в нем разных(неповторяющихся) знаков препинания.

бес12 бес12    1   04.12.2020 11:45    2

Ответы
SevenDays7 SevenDays7  03.01.2021 11:59

Пример решения задачи на языке PascalABC:

var

 J:Array of Char:=('.','!','?',',',';',':','-','(',')','"');

 T:=0;

begin

 var s:string; readln(s);

 var N:=S.ToCharArray;

 for var l:=1 to J.High do

   if N.FindAll(x->(x = J[l]) = true).Length <> 0 then inc(T);

 write('В предложении ',(T<>0)? T.ToString:'не содержится',' уникальных знаков препинания');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика