Составить программу, печатающую все простые числа, не превосходящие данного числа. паскаль абс

qwetdfgdsa qwetdfgdsa    3   07.08.2019 10:30    2

Ответы
DaniilPedrol DaniilPedrol  04.10.2020 02:50
Program Prostoe; 
Uses 
Crt; 
Var 
i, {возможный делитель} 
Number : integer; {исследуемое число} 
Begin 
ClrScr; 
writeln (‘Какое число должно быть проверено? ‘); 
read (Number); 
i := 1; 
repeat 
i := i+1; 
until Number mod i = 0; 
if Number=i 
then 
writeln (Number,’ является простым‘) 
else 
writeln (Number,’ делится на ‘,i); 
readln; 
End. 
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика