tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу паскаль,
Составить программу паскаль, которая выводит на экран олимпийские кольца. , заранее большое )
ficusborislav
3 25.07.2019 18:00
7
Ответы
KIMSEOLHYUN
03.10.2020 12:51
Uses crt,graph;
var
gd, gm, xc, yc, r, x, y: integer;
begin
clrscr;
repeat
writeln('Vvedite koordinaty levogo kolca, x=[50..300], y=[50..350]:');
readln(xc, yc);
until((xc >= 50) and (xc <= 300)) and ((yc >= 50) and (yc <= 350));
gd := 0;
initgraph(gd, gm, '');
setbkcolor(15);
cleardevice;
r := 50;
setlinestyle(0, 0, 3);
setcolor(9);
circle(xc, yc, r);
setcolor(8);{темно-серый, черный не нарисовать}
circle(xc + 2 * r, yc, r);
setcolor(12);
circle(xc + 4 * r, yc, r);
setcolor(14);
circle(xc + r, yc + r, r);
setcolor(10);
circle(xc + 3 * r, yc + r, r);
readln
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
чсссвввввавшвневаа
15.05.2020 12:30
Ченику 8 класса требовалось написать алгоритм, который определяет, принадлежит ли число x заданному числовому отрезку [a, b]. Он написал несколько вариантов условий. Какое...
FireFox2017
15.05.2020 12:30
Музыкальный фрагмент был оцифрован и записан в виде файла без использования сжатия данных. Получившийся файл был передан в город А по каналу связи за 20 секунд. Затем тот...
Tishukvasiliy
07.05.2020 08:08
Надо умножить 777 на числа что бы получилось 6-ти значное число и записано оно одними 2,3,4,5,6,7,8,9...
Tanya11011
07.05.2020 08:08
в первый день туристы ехали на велосипедах 4 часа со скоростью 15 км/ч Во второй день оно ехали на велосипедах такое же расстояние но за 5 часов. С какой скоростью ехали туристы...
saschatuba
07.05.2020 08:08
Какой формат будет в программе excel если в ячейке текст и число...
Karina1706kesa
07.05.2020 08:07
Решите анаграммы. Тема редактирование текста ВАКАПР- ВКАВТАС- МЕЗААН- БИШОКА-...
Pinno4ka
07.05.2020 08:06
Рассчитать, какой объём памяти необходим для двухминутного фильма на экране монитора с разрешением 1280 на 720 пикселей и палитрой из 1024 цветов....
Wolf2002
07.05.2020 08:06
Исследуйте и попытайтесь классифицировать анимационные эффекты, которые можно использовать в имеющемся в вашем распоряжении редакторе презентаций. Всегда ли использование...
LLeNN
07.05.2020 08:06
Каков вклад Роберта Гаскинса в создании программы для подготовки презентационных материалов с использованием компьютера?...
68Diman
07.05.2020 08:06
Напишите программу, которая вычисляет произведение всех чисел, оканчивающихся на 2, из диапазона от 0 до 50....
Популярные вопросы
Хелп хотя умру скоро от низкого...
3
Зделайте чтобы запускалось,программа ABC Pascal Program praktyka8; uses...
2
Составь конспект по математике на тему: Смешанные числа....
3
Сделайте вывод о сходстве и различиях в строении вегетативной и генеративной...
3
При зберіганнi кальцій оксиду в відкритому посуді маса його збільшується,...
3
Надо поставить герундий или to...
2
1 Complete the advice with the correct verbs. Look switch keep Hang Check...
3
Чем представлена у рыб центральная нервная система?...
2
(a×30):10=15Реши уравнения...
1
6) Work with a partner. Look at the photos, Do they match the descriptions...
2
var
gd, gm, xc, yc, r, x, y: integer;
begin
clrscr;
repeat
writeln('Vvedite koordinaty levogo kolca, x=[50..300], y=[50..350]:');
readln(xc, yc);
until((xc >= 50) and (xc <= 300)) and ((yc >= 50) and (yc <= 350));
gd := 0;
initgraph(gd, gm, '');
setbkcolor(15);
cleardevice;
r := 50;
setlinestyle(0, 0, 3);
setcolor(9);
circle(xc, yc, r);
setcolor(8);{темно-серый, черный не нарисовать}
circle(xc + 2 * r, yc, r);
setcolor(12);
circle(xc + 4 * r, yc, r);
setcolor(14);
circle(xc + r, yc + r, r);
setcolor(10);
circle(xc + 3 * r, yc + r, r);
readln
end.