Составить программу паскаль к : 1)в 200 граммах воды растворили 25 грамм поваренной соли. найдите массовую долю соли в растворе? 2)вычислить площадь и периметр прямоугольного треугольника по заданным длинам двух катетов а и b

lera1060 lera1060    3   31.05.2019 15:30    6

Ответы
Legion2K17 Legion2K17  01.10.2020 15:57
1.
Program tt;
var  A,B,C,D: Real;
begin      
Writeln ('Введите массу воды в граммах.'); Readln(A);      
Writeln ('Введите массу соли в граммах.'); Readln(B); 
D := B+A;
C := B/A;
Writeln ('Массовая доля соли в раствворе - ',C,'.');
End.    
2.
Program tt;
var  A,B,PL,Per: Real;
begin      
Writeln ('Введите длинну первого катета.'); Readln(A);      
Writeln ('Введите длинну второго катета.'); Readln(B); 
PL := (B*A)/2;
PER := sqrt(B*B+A*A)+A+B;
Writeln ('Площадь - ',PL,'.');
Writeln ('Периметр - ',PER,'.');
End.    
ПОКАЗАТЬ ОТВЕТЫ
FCMM FCMM  01.10.2020 15:57
1) Program abc;
var a,b:integer;
     x:real;
begin
writeln('Введите массу воды');
readln(a);
writeln('Введите массу раствора');
Readln(b);
x:=b/a*100;
writeln(x,'%');
end.
2)
Program tt;
var  a,b,c,P:integer;
     S:real;
begin
writeln('Введите первый катет');
readln(a);
writeln('Введите второй катет');
readln(b);
c:=sqr(a)+sqr(b);
P:=a+b+c;
S:=a*b/2;
writeln('Площадь=',S,' ','Периметр=',P);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика