Составить программу паскаль для нахождения площади трапеции с основаниями а ,б меньшн h

girina210482 girina210482    3   20.07.2019 00:30    1

Ответы
snezhanashikolai snezhanashikolai  07.08.2020 10:21
{ s(трапеции) = ((a+b)/2)*h; }
uses crt;
var
a, b, h: Integer; (Real)
s: Real;
begin
WriteLn('Введите а: ',a);ReadLn(a);
WriteLn('Введите b: ',b);ReadLn(b);
WriteLn('Введите h: ',h);ReadLn(h);
s:= ((a+b)/2)*h;
WriteLn('S = ', s);
ReadLn;
end.
Если же а и б должны быть обязательно меньше h, то:
if (a < h) and (b < h) then
begin
WriteLn('Введите а: ',a);ReadLn(a);
WriteLn('Введите b: ',b);ReadLn(b);
WriteLn('Введите h: ',h);ReadLn(h);
s:= ((a+b)/2)*h;
WriteLn('S = ', s);
ReadLn;
end;
else begin
WriteLn('Основания не меньше h!');
ReadLn;
end;
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика