Составить программу paskal для: 1)найти стороны прямоугольника, у которого известны периметр и площадь 2)дано трехзначное натуральное число. определить, является ли сумма его цифр двузначным числом

рпрситмиср рпрситмиср    3   02.07.2019 16:10    2

Ответы
egor20026 egor20026  26.07.2020 20:06
Pascal ABC
1)

Var P,S:real;
Begin
Write('P = ');Read(P);
Write('S = ');Read(S);
if (P/2-sqrt(P*P/4-4*S))/2<0 then S:=(P/2+sqrt(P*P/4-4*S))/2
else S:=(P/2-sqrt(P*P/4-4*S))/2;
WriteLn('Первая сторона равна ',S);
WriteLn('Вторая ',P/2-S);
End.

2)

Var
A:integer;
Begin
Write('A = ');Read(A);
if ((A div 10) mod 10) +(A mod 10)+(A div 100)>9 then Write('Является')
else Write('Не является')
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика