Составить программу pascal. , хелп ! ввести с клавиатуры 7 чисел и определить: 1. сумму чисел кратных 5 2. сумму отрицательных чисел кратных к 3 3. количество положительных, четных чисел кратных 7

sandershvnz sandershvnz    2   02.10.2019 18:00    0

Ответы
Anastasias223 Anastasias223  09.10.2020 12:13
Var
begin
for i:=1 to 7 do begin
write (A=); read (a);
end;
sk:=0;
s:=0;
c:=0;
for i:=1 to 7 do begin
if a mod 5=0 then begin
sk:=sk+a;
end;
if (a<0) and (a mod 3=0) then begin
s:=s+a;
end;
if (a>0) and (a mod 2=0) and (a mod 7=0) then begib
c:=c+1;
end;
end;
write (sk,s,c);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика