Составить программу,определяющую сумму положительных элементов одномерного массива b,состоящего из 14 вещественных значений

kristinavlasovа kristinavlasovа    3   06.10.2019 08:40    5

Ответы
Даша182005 Даша182005  09.10.2020 23:16

var

 B: array [1..14] of Real;

 i: Integer;

 s: Real;

begin

 Randomize;

 WriteLn ('Mассив:');

 for i := Low (B) to High (B) do begin

   B [i] := Random (100) - 50;

   Write (B [i]:5:2, ' ');

 end;

 s := 0;

 for i := Low (B) to High (B) do begin

   if B [i] > 0 then

     s := s + B [i];

 end;

 WriteLn;

 WriteLn ('Сумма положительных элементов массива = ', s:5:2);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика