Составить программу определяющую можно ли построить прямоугольник по четырем заданным отрезкам

Vironika123321 Vironika123321    1   20.07.2019 00:00    5

Ответы
милана05051 милана05051  25.08.2020 10:57
// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
  var a:=ReadArrInteger('Введите стороны',4).Sorted.ToArray;
  if (a[0]=a[1]) and (a[2]=a[3])
  then Writeln('Можно построить прямоугольник')
  else Writeln('Нельзя построить прямоугольник')
end.

Тестовые решения:
Введите стороны 6 12 12 6
Можно построить прямоугольник

Введите стороны 6 12 12 7
Нельзя построить прямоугольник
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика