Составить программу определения наибольшего из двух чисел, введенных с клавиатуры (см. пример_2). Составить программу, которая для трех чисел, введенных с клавиатуры, отрицательные возводит в 4 степень, в противном случае возводит в квадрат ИНФОРМАТИКА 8 КЛАСС

Andrey26022002 Andrey26022002    2   21.04.2020 19:56    2

Ответы
Леееера1 Леееера1  13.10.2020 15:14

Program sravnenie;

var a,b,c: real;

begin  

  readln(a,b);

  if a>b then c:=a

  else c:=b;

  writeln('Наибольшее число:', c);

end.

Program abc;

var a,b,c:real;

begin

 Write('Введите первое число:');readln(a);

 Write('Введите второе число:');readln(b);

 Write('Введите третье число:');readln(c);

 

 if a<0 then a:=sqr(sqr(a)) else a:=sqr(a);

 if b<0 then b:=sqr(sqr(b)) else b:=sqr(b);

 if c<0 then c:=sqr(sqr(c)) else c:=sqr(c);

 Writeln(a);Writeln(b);Writeln(c);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика