Составить программу определения количества положительных и отрицательных элементов массива целых чисел.

герман123344444 герман123344444    2   25.08.2019 05:50    2

Ответы
Mratom1111 Mratom1111  20.08.2020 15:23
Program n1;
const n=10;
var a: array[1..n] of integer;
i,ko,kp: integer;
begin
randomize;
ko:=0;
kp:=0;
writeln('исходный массив:');
for i:=1 to n do
begin
a[i]:=random(21)-10;
write(a[i],' ');
if a[i]>0 then kp:=kp+1;
if a[i]<0 then ko:=ko+1;
end;
writeln;
writeln('кол-во пол: ',kp);
writeln('кол-во отр: ',ko);
end.
ПОКАЗАТЬ ОТВЕТЫ
BOG5555 BOG5555  20.08.2020 15:23
Program n1;
const n=10;
var a: array[1..n] of integer;
i,ko,kp: integer;
begin
randomize;
ko:=0;
kp:=0;
writeln('исходный массив:');
for i:=1 to n do
begin
a[i]:=random(21)-10;
write(a[i],' ');
if a[i]>0 then 
if a[i]<0 then ko:=ko+1;
w
w
e
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика