Составить программу обработки списка (массива) М, состоящего из 10 элементов. Все элементы массива М, значения которых находятся в интервале от -5 до 10 возвести в квадрат. Измененный массив вывести на экран.

Marta2910 Marta2910    1   23.06.2020 14:54    1

Ответы
Dinara260803 Dinara260803  15.10.2020 14:44

arr = [int(i) for i in input().split()]

new_arr = []

for i in arr:

  if i>=-5 and i<=10:

       new_arr.append(i**2)

   else:

        new_arr.append(i)

[print(i, end=" ") for i in new_arr]

Краткий гайд:

arr -  исходный списокnew_arr - измененный список
Составить программу обработки списка (массива) М, состоящего из 10 элементов. Все элементы массива М
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика