tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу: найти
Составить программу: найти наибольшее значение функции y=ax в квадрате+bx+c на отрезке [x1,x2]
оксаночка25
1 30.07.2019 08:50
1
Ответы
alexaval1980p08mu0
03.10.2020 17:18
Var
y, a, b, c, x, x2, h, max: real;
begin
write('Введите a,b,c');
readln(a, b, c);
write('Введите x1,x2 и шаг');
readln(x, x2, h);
max := a * x * x + b * x + c;
repeat
y := a * x * x + b * x + c;
if max < y then max := y;
x := x + h;
until x > x2;
writeln(max);
end.
ПОКАЗАТЬ ОТВЕТЫ
1941г3
03.10.2020 17:18
Var
i,max,x1,x2,a,b,c:integer;
begin
read(x1,x2,a,b,c);
max:=-2147483648;
for i:=x1 to x2 do
if a*sqr(i)+b*i+c>max then max:=a*sqr(i)+b*i+c;
writeln(max);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ibondarenk2013
02.03.2021 17:50
Вычислить и вывести на экран значения функции F через код СИ...
NEADgff
02.03.2021 17:47
Чем занималась компания LEGO до производства конструкторов?...
радмирик
02.03.2021 17:47
* Укажите логический тип данных:O intlistboolfloatstrЭто обязательный вопрос....
linagurova6545
02.03.2021 17:40
Какая операция с текстом должна быть выполнена при форматировании текста?...
n254n
02.03.2021 17:39
Проект створений у середовищі Lazarus називається...
R1ceWithM3at
02.03.2021 17:38
Ребят, кто знает, напишите в каких случаях используется ручная трассировка в информатике? ...
Stikki
02.03.2021 17:36
Укажи виды роботов! если будет неправельно поставлю банк и у вас заберут ....
19942424
02.03.2021 17:33
Объясните почему получается var s, k, i: integer; begin s:= 3; i:=0 ; for k:= 0 to 9 do s:=s+2; i:=i+1; writeln(s+i); end....
Бронвин
02.03.2021 17:31
нужно написать арограмму на языке python. ...
otero02
02.03.2021 17:30
Сравни созданные слайды. Проанализируй их и рас- скажи об их оформлении.Охрана окружающей средыОХРАНА ОКРУЖАЮЩЕЙ СРЕДЫ ...
Популярные вопросы
Під час запуску ракети на навколоземну орбіту з ракетного пального...
1
Допожіть❤️ Повість Климко Г. Тютюнник...
3
Біографія Дарвіна на англійській мові 60 слів...
2
Найти фундаментальную систему решений системы уравнений;2Хвнизу...
2
Як порівняти два відрізки, два кути не накладаючи їх один на одного....
3
Які переваги мав король над іншими Феодалами в період роздробленості...
1
с английским надо сделать восьмое и седьмое не хватит дам еще...
3
Найдите сумму натуральных значений n при которых дробь 5n-16/4n-6...
3
Задание под намером 1. с действиями...
3
5. Утворити і записати ступені порівняння до поданих прикметників:...
1
y, a, b, c, x, x2, h, max: real;
begin
write('Введите a,b,c');
readln(a, b, c);
write('Введите x1,x2 и шаг');
readln(x, x2, h);
max := a * x * x + b * x + c;
repeat
y := a * x * x + b * x + c;
if max < y then max := y;
x := x + h;
until x > x2;
writeln(max);
end.
i,max,x1,x2,a,b,c:integer;
begin
read(x1,x2,a,b,c);
max:=-2147483648;
for i:=x1 to x2 do
if a*sqr(i)+b*i+c>max then max:=a*sqr(i)+b*i+c;
writeln(max);
end.