tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу нахождения
Составить программу нахождения всех трехзначных чисел, таких, что сумма цифр равна а, а само число делится на в (а и в вводятся с клавиатуры).
kushtueva
3 20.09.2019 16:30
2
Ответы
goodwar40
08.10.2020 04:58
Var a,b,s,q,w,e:Integer;
begin
Read(a,b);
for s:= 100 to 999 do
begin
q:= s div 100;
w:= s div 10 mod 10;
e:= s mod 10;
if (q+w+e=a) and(s mod b = 0) then
WriteLn(s);
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
jordan15
19.04.2019 13:14
Напишите программу ввода четырех символеных переменных ch1 ch2 ch3 ch4 определить количество нулей сркди этих символов замените символ 《прбел》на символ z...
Jlu4shiyFisik
19.04.2019 13:11
Сиспользованием интегрированной среды разработки lozarus...
mariauizly88
19.04.2019 13:03
Напишите программу ввода четырех символьных переменных ch1 ch2 ch3 ch4 определить количество нулей сркди этих символов замените символ 《прбел》на символ z...
Мышонок11111
12.03.2021 20:08
Созданным электронным таблицам MS Excel можно построить различные виды диаграмм...
vit7201
12.03.2021 20:10
Напишите самое первое действие при построении диаграммы к созданной таблице – . ...
RetoGero
12.03.2021 20:11
с информатикой.. Число 10001112 в восьмиразрядном представлении имеет вид 11000111 . Десятичное число является отрицательным числом положительным числом...
Kvintsekstakkord
12.03.2021 20:14
Созданным электронным таблицам MS Excel можно построить различные виды диаграмм. ...
kunicyna1805
13.08.2019 23:30
Ввашем распарежение 2 кувшина один на 3 литра а один на 8 как с этих кувшинов из реки набрать 7 литров вады...
ПеЧеНьКа5608
13.08.2019 23:30
Робот на клетчатой дорожке собирает детали конструктора,действуя следующим образом: начало пока на клетке,где стоит робот,есть деталь собрать детали с клетки,где стоит...
Vad1mm
13.08.2019 23:30
Дима недавно сменил провайдера. он не помнит какой конкретно у него тариф, но знает, что файл размером 1253 кб он передает за 23 секунд. сколько полных мб данных он...
Популярные вопросы
Як характеризують Дженні її музичні уподобання?(Ерік Сігел Історія...
3
1. Что такое личность? 2. Какое значение имеет самообразование?...
1
Центри найважливіших безумовнихрефлексів містяться уа) корі півкуль;б)...
1
К депутату городской Думы обратился В. по во несоблюдения работодателем...
3
Чи подобається вам «новий» Конрад? Думку обгрунтуйте...
2
Українська мова та читання 2 клас частина 2 до ть сторінка 75 відповідь...
1
Найдите величину угла dok если ОК биссектриса угла аод доб=110 ответ...
2
Текст (1) Рослини - перша ланка ланцюга живлення, його основа. (2)...
3
Ланцюг перетворення: кальцій карбід - кальцій гідроксид - кальцій...
2
физика соррррррр ауууууу зайдите ауууу соррррр...
1
begin
Read(a,b);
for s:= 100 to 999 do
begin
q:= s div 100;
w:= s div 10 mod 10;
e:= s mod 10;
if (q+w+e=a) and(s mod b = 0) then
WriteLn(s);
end;
end.