Составить программу нахождения суммы чисел четырехзначного числа

Margo80m Margo80m    1   16.03.2019 13:20    1

Ответы
Sasha11111222 Sasha11111222  07.06.2020 02:00

Program exs;

var a, i, sum : integer;

 

begin

sum:= 0;

   readln(a); {Считывание числа}

   for i:= 1 to 4 do begin

      sum:=sum + (a mod 10); {Находим остаток от деления на 10}

      a:=a div 10;                   {Выкидываем найденную цифру из числа}

   end;

writeln(sum);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика