tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу ,находящую
Составить программу ,находящую кол-во и сумму цифр пяти данных целых чисел ,используя процедуру
Salazar01
1 04.06.2019 10:20
1
Ответы
berezenetsdash
05.07.2020 12:13
Var i,x,k,s:integer;
function Sum(x:integer):integer;
var
t:string;
i:integer;
begin
s:=0;
t:=IntToStr(x);
for i:=1 to length(t) do s:=s+StrToInt(t[i]);
result:=s
end;
function Kol(x:integer):integer;
var t:string;
begin
t:=IntToStr(x);
result:=length(t)
end;
begin
for i:=1 to 5 do
begin
write('Введите число ',i,': ');
readln(x);
k:=Kol(x);
s:=Sum(x);
writeln('Количество цифр ',k,'; сумма цифр ',s)
end
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
valeriybalybin
14.08.2019 22:50
Дано целое число.подсчитать в нём произведение цифр,которые расположены на нечётных позициях....
Darhanfan
10.07.2019 03:50
Pascal на карте координаты начала и конца строящегося прямолинейного участка шоссе обозначены как (x1; у1 ) и (x2; у2 ). карьер, откуда можно брать гравий для стройки,...
Kira6666666666
10.07.2019 03:50
1условие в блок-схеме алгоритма ветвления заключается: а)прямоугольник b)овал c)шестиугольник d)ромб 2укажите вид алгоритма: a)линейный в)неполная форма структуры...
zaporozkayaoks
16.06.2019 01:40
Винтик поставил на скачивание файл и определил, что закачка займёт 20 минут. через 4 минуты на этом же компьютере шпунтик поставил на скачивание свой файл. после...
simsnothave
17.09.2020 20:11
3. Сколько места в памет нало выделить для хранения 512-цветного рисунка размером 920 x 480 пиксела?4. Сколько места в памяти надо выделить для хранения 1024-цветногорисунка...
Азим721
17.09.2020 21:23
Сумма 3 чисел равна 50 Карен вычла из каждого слагаемого одно и тоже секретное число и получила 24...
2006Liora
17.09.2020 21:24
Как запустить любую исполняемую программу? Перечислите свои варианты...
refdiamond
17.09.2020 20:15
Найдите такое минимальное целое положительное число N, что если прибавить его к 1111 10-десятых и перевести результат суммирования в двоичную систему счисления,...
mashuna1
17.02.2021 09:18
написать программу которая принимает на вход набор чисел, составляет из них список вычисляет среднее арифметическое равное 5...
varfo
17.11.2020 18:34
Якщо приймати душ 3 рази на тиждень, то витрата води така сама, як прийняти ванну 1 раз на тиждень. На скільки відсотків витрачається менше води за один прийом...
Популярные вопросы
ВАЩЕ МНОГО ДАЮ Замени k одночленом так, чтобы получился квадрат...
3
Кратко охарактерезуйте роль российской культуры в мировой культуре....
1
Составить план действий от имени Бориса Годунова. История 7...
2
Напишите формулы которые задают эти линнейные функции...
3
Найдите пары равных треугольников и докажите их равенства умоляю)))...
3
На какие 3 части принято делить всю территорию Северного Кавказа...
1
Учитывая значение, выберите лишний союз. оттого или но зато...
1
Вынеси общий множитель за скобки: 3tu+2,4tv−4,2tp...
2
Выпиши из данного ниже текста (с большой буквы без точки в конце)...
3
Округлите число до сотых 109, 237...
3
function Sum(x:integer):integer;
var
t:string;
i:integer;
begin
s:=0;
t:=IntToStr(x);
for i:=1 to length(t) do s:=s+StrToInt(t[i]);
result:=s
end;
function Kol(x:integer):integer;
var t:string;
begin
t:=IntToStr(x);
result:=length(t)
end;
begin
for i:=1 to 5 do
begin
write('Введите число ',i,': ');
readln(x);
k:=Kol(x);
s:=Sum(x);
writeln('Количество цифр ',k,'; сумма цифр ',s)
end
end.