tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу на
Составить программу на языке «рascal» для вычисления значений функции: 3sinx+8, если х
kpy4
3 01.07.2019 20:10
3
Ответы
LizaMelehina457
26.07.2020 07:20
uses Crt;
const
Pi=3.14159265;
var
x,y:real;
begin
ClrScr;
x:=0;
while x<=Pi do begin
if x<Pi/2 then y:=3*sin(x)+8
else y:=4*cos(2*x);
Writeln('x=',x:8:5,', y=',y:8:5);
x:=x+Pi/10
end;
ReadKey
end.
Тестовое решение:
x= 0.00000, y= 8.00000
x= 0.31416, y= 8.92705
x= 0.62832, y= 9.76336
x= 0.94248, y=10.42705
x= 1.25664, y=10.85317
x= 1.57080, y=-4.00000
x= 1.88496, y=-3.23607
x= 2.19911, y=-1.23607
x= 2.51327, y= 1.23607
x= 2.82743, y= 3.23607
x= 3.14159, y= 4.00000
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
timekid
30.11.2020 11:09
Даны два (три) натуральных четырёхзначных числа. Расположить их в порядке неубывания сумм крайних цифр.С++первый код для 2 чисел, второй для 3...
COCOBAKUOFFICI
30.11.2020 11:09
Информационное сообщение объемом 300 байт содержит 800 символов. Какова мощность алфавита?...
polisavostina
06.07.2019 16:30
Скорость передачи данных модемом по протоколу v.34 составляет 28800 бит/c. при данного протокола необходимо передать файл размером 72000 байт. определите время передачи...
Stultus
03.10.2019 19:45
Информатика 9 класс. , ! определите значение целочисленной переменной х после выполнения следующего фрагмента решением)...
mashenkamini
21.03.2019 22:51
Вася стоит на первой ступеньке свежепокрашенной лестницы и собирается подняться на самую верхнюю, двенадцатую ступеньку. некоторые ступеньки лестницы, а именно, ступеньки...
27081984e
21.03.2019 22:50
Как на honor 6a включить подавление красных глаз? ...
YummyGirl
21.03.2019 22:49
Срешением четвертная оценка зависит информатика 9 класс...
Александра030307
21.03.2019 22:34
Вопрос №8: найти все ошибки в данном фрагменте программы var a: = array[1…20] ofinteger; i, k: integer begin for i : = 1 downto n do begin a[i]: = random(30); end; readln(k);...
arlashmanov
15.04.2020 09:06
Составьте алгоритм в результате выполнения которого запрашивается число. Если это число находится в пределах от -1 до +1, то сообщается число 0, если число не находится...
Marii111
15.04.2020 09:07
Python.Написать программы и прислать скриншоты кода программ: 1. Площадь прямоугольника Напишите программу, вычисляющую площадь произвольного прямоугольника из двух введенных...
Популярные вопросы
Из какой былины эти строчки ? о каком подвиге ильи мурома расказывается...
1
5) какой масштаб мельче: а) 1: 20000 или 1: 1000 б) 1: 8300000 или...
2
Твір на тему опиши зимову прогулянку парком...
2
С! яка літера ображається на те, що вона не пишеться на початку слова?...
2
Какова %-ная концентрация раствора, полученного сливанием 120г 10%-го...
1
Составьте рассказ по картине маленькие путешественники. катя дудник)...
3
6sin^2 x - 5 sin x +1 больше или меньше 0...
1
Чему это будет равно? arccos(sin( 5pi/6))...
2
Сочинение по казахскому языку на тему менің қонақ үйім (моя гостиница)...
2
Что такое полные двусоставные предложения и неполные двусоставные...
3
uses Crt;
const
Pi=3.14159265;
var
x,y:real;
begin
ClrScr;
x:=0;
while x<=Pi do begin
if x<Pi/2 then y:=3*sin(x)+8
else y:=4*cos(2*x);
Writeln('x=',x:8:5,', y=',y:8:5);
x:=x+Pi/10
end;
ReadKey
end.
Тестовое решение:
x= 0.00000, y= 8.00000
x= 0.31416, y= 8.92705
x= 0.62832, y= 9.76336
x= 0.94248, y=10.42705
x= 1.25664, y=10.85317
x= 1.57080, y=-4.00000
x= 1.88496, y=-3.23607
x= 2.19911, y=-1.23607
x= 2.51327, y= 1.23607
x= 2.82743, y= 3.23607
x= 3.14159, y= 4.00000