Составить программу на языке программирования visual c++! два автомобиля движутся по кольцевой дороге длины l в противоположных направлениях. они начинают движение из одной точки и едут с постоянными скоростями v1 и v2 соответственно. требуется определить, на каком расстоянии друг от друга они окажутся в момент времени t. на вход 4 натуральных числа l, v1, v2, t, разделенных пробелом. все числа не превосходят 100. выведите расстояние между автомобилями в момент времени t – длину кратчайшей из двух дуг дороги между автомобилями.

lixonilya lixonilya    1   17.05.2019 13:30    14

Ответы
aigul841107gMailcom aigul841107gMailcom  30.09.2020 19:17

#include<iostream>
using namespace std;
int main(){
  int l,v1,v2,t;
  cin>>l>>v1>>v2>>t;
  int x1 = (t * v1)%l,x2 = (-t*v2)%l;
  if(x1<0) x1=l-x1;
  if(x2<0) x2=l+x2;
  cout<<min(abs(x1-x2),abs(l-x1-x2));
}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика