Составить программу на языке паскаль вводится натуральное число х (х> 9). 1. определить, ли по значению первая и последняя цифры.. например, ввод: 727 вывод: число начинается и заканчивается цифрой 7 ввод 123 вывод первая и последняя цифры не .

ryenasssss ryenasssss    3   27.07.2019 21:10    1

Ответы
titsdeil titsdeil  03.10.2020 14:40
Var a,b,c:integer;
begin
write('a = '); readln(a);
b:=a mod 10;
c:=a;
while c>9 do c:=c div 10;
if (a>9) 
 then if b=c
        then writeln('Число начинается и заканчивается цифрой ',c)
        else writeln('Первая и последняя цифры не совпадают')
 else writeln('Число < 10');
end.

Пример:
a = 65478
Первая и последняя цифры не совпадают
ПОКАЗАТЬ ОТВЕТЫ
89538277266 89538277266  03.10.2020 14:40
Прога в приложении
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика