Составить программу на языке паскаль с random дано a[i]∈[-13,8] найти произведение нечетных отрицательных чисел n=5

kizzka kizzka    3   23.09.2019 19:20    4

Ответы
niminol niminol  08.10.2020 13:07
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(5,-13,8).Println.Where(t->(t<0) and t.IsOdd).ToArray;
  if a.Count>0 then a.Aggregate(1,(i,j)->i*j).Println
  else Writeln(0)
end.

Пример
-2 -6 -6 -7 -13
91
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика