Составить программу на языке паскаль, для решения : 1".зная цену компьютера b рублей,определить хватит ли покупателю на a рублей купить компьютер? " 2."зная длину забора d метров,определить хватит ли сетки а метров.чтобы обнести этот забор"?

Anny2404 Anny2404    2   13.07.2019 07:30    5

Ответы
ЛимАнель ЛимАнель  13.08.2020 15:33
1)
var
a,b,e:real;
begin
write('Сколько стоит компьютер - ');
readln(b);
write('Сколько денег у покупателя - ');
readln(a);
e:=a-b;
if e>0 then
 writeln('Покупателю хватит денег на покупку компьютера ценой - ',b,'руб.')
else
 begin
  e:=e*(-1);
  write('Покупатель не сможет купить компьютер ценой - ',b,'руб. Ему не хватает - ',e,'руб.');
 end;
end.
2)
var
a,b,e:real;
begin
write('Длина забора (м) - ');
readln(b);
write('Длина сетки (м) - ');
readln(a);
e:=a-b;
if e>0 then writeln('Сетки хватит чтобы обнести забор.')
else
 begin
  e:=e*(-1);
  write('Сетки не хватит чтобы обнести забор.');
 end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика