Составить программу на языке паскаль для нахождения максимального элемента в массиве из 7 элементов(целых двухзначный чисел) заданного случайным образом

0ananasik0 0ananasik0    1   22.05.2019 07:40    3

Ответы
Boodmi Boodmi  01.10.2020 06:16


Program nechaeva97;
uses crt;
const n=7;
var
  i,t,max:integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  max:=random(90)+10;
  write (max:5);
  for i:=2 to n do
    begin
      t:=random(90)+10;
      write (t:5);
      if max<t then max:=t;
    end;
  writeln();
  writeln('Максимальный элемент массива равен= ',max);
end.

ПОКАЗАТЬ ОТВЕТЫ
kartoshechka49 kartoshechka49  01.10.2020 06:16

uses crt;
var a:array [1..100] of integer;
max,i,n:integer;
begin
  randomize;
  for i:=1 to 7 do
  begin
    a[i]:=random(90)+10;
    write(a[i],' ');
  end;
  writeln;
  max:=a[1];
  for i:=1 to n do
    if a[i]>max then max:=a[i];
  write('max=',max);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика