Составить программу на языке паскаль. а) вычислить среднее арифметическое элементов массива а(20) равных за данному числу а. б) вычислить произведение модулей элементов массива а(20).

KllaBer KllaBer    1   09.09.2019 10:10    1

Ответы
oksanavolkova3 oksanavolkova3  07.10.2020 02:54
Первая задача:
var
  i, c, sum: shortint;
  sr: real;
  m: array[1..20] of shortint;

begin
  sum := 0;
  readln(c);
  for i := 1 to c do
  begin
    readln(m[i]);
    sum := sum + m[i];
  end;
  sr := sum / c;
  sr := round(sr * 100) / 100;  //если округлять не нужно, удали эту строчку
  writeln('Среднее арифметическое: ', sr);
end.

Вторая задача:
var
  i, c: shortint;
  p: integer;
  m: array[1..20] of shortint;

begin
  p := 1;
  readln(c);
  for i := 1 to c do readln(m[i]);
  for i := 1 to c do p := abs(p * (m[i]));
  writeln('Произведение всех модулей массива: ', p)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика