Составить программу на языке pascal: решить квадратное уравнение вида а*х*х+в*х+с=о для произвольных а, в, с.

nikitazaharov28 nikitazaharov28    2   13.09.2019 10:10    6

Ответы
superman48 superman48  07.10.2020 11:38
Текст плохо форматируется, поэтому скину файлом.
ПОКАЗАТЬ ОТВЕТЫ
Mihan4ik Mihan4ik  07.10.2020 11:38
//Pascal
var
  a, b, c, d, x1, x2: real;
begin
  write('Введите a = '); readln(a);
  write('Введите b = '); readln(b);
  write('Введите c = '); readln(c);
  if ((a = 0) and (b = 0) and (c = 0)) then
    writeln('X любое')
  else
  if a <> 0 then
  begin
       d := sqr(b) - 4 * a * c;
       if (d > 0) then
       begin
            x1 := (-b+sqrt(d))/(2*a);
            x2 := (-b-sqrt(d))/(2*a);
            writeln('x1 = ', x1);
            writeln('x2 = ', x2);
       end
       else
       if d = 0 then
       begin
            x1:=-b/(2*a);
            x2:=x1;
            writeln('x1 = ', x1);
            //writeln('x2 = ', x2);
       end
       else
       if d < 0 then
          writeln('Корней нет.');
  end
  else
  if (a = 0) and (b = 0) then
    writeln('Решений нет.')
  else
  if (a = 0) then
  begin
    x1 := (-c)/b;
    writeln('x = ', x1);
  end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика