Составить программу на языке Pascal для нахождения гипотенузы с и площади S прямоугольного треугольника, если известны его катеты а и в (тремя : обычная линейная программа, программа с использованием процедуры и программа с использованием функции)

artemonimus artemonimus    1   26.11.2021 12:59    5

Ответы
GizaHelinc GizaHelinc  01.01.2022 21:24

var

 a,b,s,c:real;

begin

 write('a b:');readln(a,b);

 c:=sqrt(sqr(a)+sqr(b));

 S:=a*b/2;

 writeln('c:',c,', S:',S);

end.

var

 a,b,s,c:real;

procedure Sc(var a,b:real);

 begin

   c:=sqrt(sqr(a)+sqr(b));

   S:=a*b/2;

   writeln('c:',c,', S:',S);

 end;

begin

 write('a b:');readln(a,b);

 Sc(a,b);

end.

var

 a,b,s,c:real;

function Sss(var a,b:real):real;

 begin

   Sss:=a*b/2;

 end;

function Ccc(var a,b:real):real;

 begin

   Ccc:=sqrt(sqr(a)+sqr(b));

 end;

begin

 write('a b:');readln(a,b);

 S:=Sss(a,b); c:=Ccc(a,b);

 writeln('c:',c,', S:',S);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика