Составить программу на языке c++ которая будет определять количество точек с целочисленными координатами принадлежащих кругу с радиусом r , с центром в начале координат.

zheckachernev zheckachernev    1   02.10.2019 22:40    3

Ответы
Maria8812 Maria8812  09.10.2020 12:40

#include <iostream>


using namespace std;



int main() {


  long long i,j,r,n;


  cout<<"r = ";  cin>>r;


  i=r; j=1; n=0;


  while (i>=1) {


      while (i*i+j*j<=r*r) j=j+1;


      n=n+r-j+1;


      i--;


  }


  n=2*(2*r+1)-1+4*r*r-n*4;


  cout<<n<<endl;


  system("pause");


  return(0);


}



Составить программу на языке c++ которая будет определять количество точек с целочисленными координа
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика