Составить программу на вход количества чисел,а затем вводятся сами числа. составить программу для нахождения макс и мин из этих чисел. каким образом делать, не знаю.

дима4455 дима4455    1   25.07.2019 09:40    3

Ответы
muhkirill2017 muhkirill2017  03.10.2020 12:27
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var a,i,min,max,n:integer;
begin
  write('Введите количество чисел ');
  readln(n);
  min:=MaxInt; //считаем, что мимнимальное - самое большое целое
  max:=-MaxInt;//считаем, что максимальное - самое маленькое целое
  for i:=1 to n do begin
    readln(a);
    if a>max then max:=a;
    if a<min then min:=a;
  end;
  writeln('Максимальное: ',max,'  минимальное: ',min);
end.

Тестовое решение:
Введите количество чисел 5
23
12
44
10
15
Максимальное: 44  минимальное: 10
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика