Составить программу на паскале: заполнить массив вм случайными числами из диапазона от 1 до 150. размерность массива 20.распечатать массив на экране в строку. найти сумму всех нечётных чисел массива. результат вывести на экран в отдельной строке.

superparty superparty    1   06.10.2019 07:20    5

Ответы
semabulov semabulov  09.10.2020 23:10
program n_1; const  n = 20; var  a: array [1..n] of integer;  i, sum: integer; begin  sum := 0;  for i := 1 to n do    begin    a[i] := random(150) + 1;    write('a[', i, '] = ', a[i], '; ');    if odd(a[i]) then inc(sum, a[i]);    end;  writeln ();  write('sum = ', sum); end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика