Составить программу на паскале вычислить сумму чисел натурального ряда, делящихся на 3, до тех пор, пока сумма не превысит 500. определить число членов суммы. значение суммы и число ее членов вывести на экран с соответствующими комментариями.

prisheplub prisheplub    1   28.06.2019 02:40    6

Ответы
vlad199411003 vlad199411003  22.07.2020 13:13
Вроде получилось:

var a,b,s:integer; 
begin
write('Числа = ');
for a:=1 to 100 do
begin
b:=a mod 3;
if (b = 0) then
begin
write(a,', ');
s:=s+a;
if((s > 500) and (s<520)) then break;
end;
end;
writeln('Сумма чисел = ', s);
end.

Результат:

Составить программу на паскале вычислить сумму чисел натурального ряда, делящихся на 3, до тех пор,
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика