tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу
Составить программу на паскале сортировки массива по возрастанию
vitalii1962svet
1 24.05.2019 19:30
3
Ответы
zonanip
20.06.2020 17:39
Сортировка методом пузырька:
const n=10;
Var a:array[1..n] of integer; i,j,b:integer;
Begin
for i:=1 to n do read(a[i]);
for i:=1 to n-1 do
for j:=i+1 to n do
if a[j]<a[i] then
begin
b:=a[i];
a[i]:=a[j];
a[j]:=b;
end;
for i:=1 to n do write(a[i],' ');
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
АлинаКравченко
26.03.2020 17:18
решить задачу В программу вводится десятичное целое число N (1 переводящую это число в двоичную систему счисления и печатающую ее на экране....
keklol1990
26.03.2020 17:17
Запиши число 14567 в развёрнутом виде, начиная со старшего разряда....
tflash191
26.03.2020 17:15
Напишите, что будет напечатано после выполения данного фрагмента программы?...
Aleksstak
26.03.2020 17:15
Что из этих вариантов верно?...
tibefp33org
26.03.2020 17:06
Результатом выполнения за является таблица с отобранными данными. Где хранится эта таблица?...
сауле49
26.03.2020 17:05
Определи основание системы счисления числа 449 10...
Karina5252
26.03.2020 16:56
Что нужно вписать в строку var . (a, b - действительные числа)...
yaxyeu
26.03.2020 16:30
Напишите решение в паскале, с за чисел от пользователя(readln)...
smirnovadara747
26.03.2020 16:29
Информатика: работа в табличном процессоре. Решите...
Машуня55
26.03.2020 16:27
решить задание в прикреплённом файле...
Популярные вопросы
90. расставьте цифры в пустых клетках так, чтобы получились верные...
3
Выручайте , у меня будет контрольная по . решите я буду ! все свои...
2
5класс номер 534 бірінші жұмысшы 27 тетік дайындау үшін 15 3/4...
1
Яка експозиція і кульмінація в і про схід і захід...
2
Мне нужен диалог на любую тему из 9 предложений...
2
На какое натуральное число можно сократить дробь , если известно...
3
Люди іть треба скласти розповідь за початком одного разу ми знайшли...
2
На координатной прямой задана точка яа(5). найдите координаты точек,...
3
Каким логическим выражением описывается схема? ...
2
Чем брал взятки хлестаков в комедии ?...
2
const n=10;
Var a:array[1..n] of integer; i,j,b:integer;
Begin
for i:=1 to n do read(a[i]);
for i:=1 to n-1 do
for j:=i+1 to n do
if a[j]<a[i] then
begin
b:=a[i];
a[i]:=a[j];
a[j]:=b;
end;
for i:=1 to n do write(a[i],' ');
End.