Составить программу на паскале. сформировать двумерный массив, состоящий из положительных и отрицательных элементов. заменить положительные элементы-единицей, а отрицательные- нулем

машазайка1 машазайка1    1   09.09.2019 03:50    7

Ответы
missisivun2017 missisivun2017  03.08.2020 22:32
Begin
  var n:=ReadInteger('n = ');
  var m:=ReadInteger('m = ');
  Writeln('Исходная матрица:');
  var a:=MatrRandom(n,m,-20,20); 
  a.Println(4);
  for var i:=0 to a.RowCount-1 do
    for var j:=0 to a.ColCount-1 do
      if a[i,j]>0 then a[i,j]:=1 else a[i,j]:=0;
  Writeln('Измененная матрица:');
  a.Println(4)
end.

Пример:
n =  4
m =  5
Исходная матрица:
   7  -8  -7  -5  -7
   2   4  -3  -2 -13
  14   5 -12   9  20
  12  11  18  -3   7
Измененная матрица:
   1   0   0   0   0
   1   1   0   0   0
   1   1   0   1   1
   1   1   1   0   1
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика