СОСТАВИТЬ ПРОГРАММУ НА ПАСКАЛЕ!
Рассчитать сумму кубов всех положительных значений и их количество для функции

Составить программу для табулирования функции на промежутке [0;4] с шагом h=0,5.

sashasas12365 sashasas12365    2   01.03.2020 00:46    5

Ответы
moakoroleva moakoroleva  11.10.2020 15:41

===== PascalABC/NET =====

begin

 var (a, b, h) := (0.0, 4.0, 0.5);

 var n := Trunc((b - a) / h) + 1; // количество точек

 var (s, k) := (0.0, 0);

 for var i := 0 to n - 1 do

 begin

   var x := a + i * h;

   var y := 3 * x * x + 2 * Cos(Cos(x));

   Writeln(x:3:1, y:20:15);

   if y > 0 then

   begin

     Inc(k);

     s += y ** 3

   end

 end;

 Println('Сумма кубов положительных значений функции равна', s);

 Println('Количество вошедших в сумму значений равно', k)

end.


СОСТАВИТЬ ПРОГРАММУ НА ПАСКАЛЕ! Рассчитать сумму кубов всех положительных значений и их количество д
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика