Составить программу на паскале находящюю самое длинное слово в строке начинающееся на букву а , и выводящуюю количество букв в

малика3024 малика3024    1   09.03.2019 12:30    2

Ответы
Gfykfyj Gfykfyj  24.05.2020 10:46

var s:string;
i,n,max:byte;

begin
n:=0;i:=1;max:=0;
write('Введите s -> ');readln(s);

while i<=length(s) do begin
if (i=1) or (s[i]=' ') then begin
if i <> 1 then inc(i);
if (i<=length(s))and((s[i]='a') or (s[i]='A')) then

while i<=length(s) do
if s[i]<>' ' then begin
inc(n);
inc(i);
end else break;
end;
inc(i);

if max<n then max:=n;
n:=0;
end;
write('Длина самаго длинного слова на букву A = ',max);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика