Составить программу на паскале, использовать неравенства x^2 + y^2 < = r^2 если точка принадлежит кругу и x^2 + y^2 > r^2 в противном случае

DoctorVatson1 DoctorVatson1    1   27.07.2019 23:00    2

Ответы
aleksandra20181 aleksandra20181  03.10.2020 14:48
Var x, y, x1, y1, r: real;
begin
write('Введите координаты точки X, Y: ');
read(x, y);
write('Введите координаты центра окружности X, Y: ');
read(x1, y1);
write('Введите радиус окружности R: ');
read(r);
if sqr(x-x1) + sqr(y-y1) <= r*r then writeln('Точка принадлежит кругу')
else writeln('Точка не принадлежит кругу')
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика