Составить программу на паскале: ) для десяти чисел введенных с клавиатуры все отрицательные сложить а положительные умножить

ekzz1 ekzz1    3   27.06.2019 01:10    6

Ответы
alenasen12345 alenasen12345  21.07.2020 16:59
Var a,b,c,d:integer;
beginwriteln('введите десять чисел');
readln(a);
b:=1;
d:=0;
for c:=2 to 10 do
begin
readln(a);
if (a > 0) then b:=b*a;
if (a < 0) then d:=d+a;
end;
writeln('положительные ',b);
writeln('отрицательные ',d)
end.
ПОКАЗАТЬ ОТВЕТЫ
kotiki2017 kotiki2017  21.07.2020 16:59
Const
  N = 10;

var
  x, i, minus, plus:integer;

begin
  plus:=-1;
  minus:=0;
  for i:=1 to N do
  begin
    readln(x);
    if x<0 then
      minus:=minus+x;
    if x>0 then
      if plus = -1 then      
        plus:=x
      else
        plus:=plus*x;
  end;
  writeln('Сумма отрицательных чисел: ', minus);
  if plus = -1 then
    writeln('Положительных чисел нет')
  else
   writeln('Произведение положительных чисел:', plus);
end. 
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика