Составить программу на ''pascal abc'') дана строка, содержащая текст на языке, и некоторая буква. подсчитать, сколько слов начинается с указанной буквы.

burlakovartemyoxcyjx burlakovartemyoxcyjx    2   09.06.2019 01:20    2

Ответы
приветядима приветядима  07.07.2020 23:24
var
  str : string;
  i, j: byte;
  schr: char;

begin
  readln(str); //Вводим строку
  str := ' ' + str;  //Это чтобы не удлинять условие, что ниже
  readln(schr); //Вводим символ
  for i := 2 to length(str) do
    if ((upcase(str[i]) = upcase(schr)) and (str[i - 1] = ' ')) then
      inc(j);
  writeln(j);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика