Составить программу на pascal 1. составить программу, которая определяет является ли сумма цифр двузначного числа четной или нечетной 2. составить программу, которая определяет имеет ли уравнение a(x)^(2) + bx + c решения, где a, b и c данные вещественные числа подалуйста, нужно

jyljokgorsheni1 jyljokgorsheni1    2   26.08.2019 21:10    2

Ответы
marinamashkina2 marinamashkina2  09.09.2020 07:59
1)

Program n1;
var n: integer;
begin
readln(n);
if( (n mod 10)+(n div 10) )mod 2=0 then write('четная') else write('нечетная');
end.

2)
Program n1;
var a,b,c: real;
begin
readln(a,b,c);
if (b*b-4*a*c)<0 then write('не имеет решения') else write('имеет решения');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика